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Network GradeBook Overview
General

The JMC GradeBook allows teachers to keep track of student grades on assignments,
tests, quizes, projects, etc. as well as calculate and submit term (semester, quarter,
trimester, hex) and midterm grades and comments to the office via a local area network.

Teachers may also assess student progress on standards and benchmarks by calculating
benchmark results based on assignment scores and standard results based on benchmark
results.  If desired, these results may be hand-entered rather than calculated.

The JMC GradeBook also allows teachers to create seating charts and progress reports.

IMPORTANT:  Please regularly make back-ups of the JMC GradeBook folder.  For
a detailed example of the back-up process, see the section at the end of this document
entitled “Backing Up your GradeBook Software” on page 38.

Using the GradeBook program:
To use the GradeBook program simply open (double-click) the GradeBook folder.
Inside the GradeBook folder, locate and open (double-click) the JMC GradeBook icon.

Setting Up the GradeBook:
The initial setup of the GradeBook for individual teachers is done once.

In the Office
Your GradeBook disk will be set up for you in the office, identifying you as the
owner.

Over a Network
1. If your disk was not set up in the office, open the JMC GradeBook v3.5

application.

2. Select the volume on which the JMC data folder resides.

3. Locate and select your name in the list of teachers.

4. Click on Accept.  The Teacher Verification window will appear.

Note:    Once a teacher is selected and verified, he/she may not be
changed.

5. If your name is displayed, click on Correct.
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Using the GradeBook for Standards and Benchmarks Assessment:
The major steps for doing Standards and Benchmarks Assessment using the GradeBook
are as follows:

1. The teachers’ courses must first be instanced in the JMC Office Application for
the standards and/or benchmarks to be assessed from the GradeBook.

2. If a teacher wants to have calculated results for Standards and Benchmarks, they
would need to have the GradeBook set up normally with grade cutoffs defined,
categories and assignments specified, and scores entered for assignments from
which the results are to be calculated.

3. From the GradeBook’s File menu, select Office to Teacher to bring over local
copies of the standards and benchmarks definitions from the office to the
GradeBook.  This step may need to be repeated periodically as standards and
benchmarks definitions get updated in the Office Application.

4. Link assignments to benchmarks on the Categories and Assignments screen
from the Scores menu.

5. Modify the weighting of benchmarks within a standard AND/OR assignments
within a benchmark on the Standards and Benchmarks screen from the Scores
menu.

6. Generate assessments (result sets) on the Edit Assessments for a Course or
Grade...  or Edit Assessments for a Student… screens in the Edit Menu of the
GradeBook.

7. Submit results from the teacher's GradeBook by doing a Teacher to Office from
the File menu of the GradeBook.

8. The office staff will select Teacher to Office via Network from the JMC Office
Application to pull in the teachers’ submissions.  The results will then be
displayed and editable on the Edit Student Standards and Benchmarks Results
screen of the JMC Office Application.

Note:  Disk-based GradeBooks do not include the Standards and Benchmarks
screens.
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GradeBook Basics
Establishing a Password for the GradeBook:

Setting a password (optional) restricts program use to the individual instructor.

1. To set or change a password, select the Set Password option in the File menu.

2. Type your new password.

3. Click OK.

4. Retype the password for verification.

5. Click OK.  If the two entries match, the password is saved.

Note:    If you forget your password contact JMC.

Office to Teacher:
This option is used to periodically update the student class lists and standards and
benchmarks definitions for your student gradebook data.

In the Office
Your student class lists will be updated for you in the office.

Over a Network
Under the File menu, select Office to Teacher.  You may be asked to locate the
JMC data folder.

Note:  Your network administrator will be able to tell you the location of the data
folder.

Note:  This action will update your  class lists standards and benchmarks
definitions.

Calculating Grades from Scores and Entering/Editing Grades and
Comments:

1. Select Course Grades under the Edit menu.  The screen will appear similar to
Figure 1.
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Figure 1: Course Grades screen.

2. Select the desired course/period/term from the pop-up menu at the top of the
window.

3. If you have defined grade cut-offs and have entered assignment scores,  all you
need to do is to go to Calculate Grades from Scores under the Options menu.
This action brings the grades from the Assignment Scores screen.

Note:    If you manually change a grade, it will lock and a box will appear
around it.

4. Edit/Enter grades for the students by clicking on the desired grade.  Comments are
also entered by clicking on the desired comment on the right-hand side of the
window.

Making several entries
If you wish to make several entries for a student before moving to the next student,
use the Entry Mode check-boxes at the bottom to control where the selection
rectangle moves.  The selection rectangle will move across to a column having a
checked Entry Mode box.  If no Entry Mode boxes are selected, the selection
rectangle will move to the next student.

Note:  To enter the same grade for more than one student, click and drag to select
the grade boxes for the desired students and grades, and then click on the grade.
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Entering Weights for Calculation of Course Grades:

To have the course grade calculated
1. Use the boxes above the marking period and exam grade columns to select the

desired weights.

2. Click on the weight and select a new weight from the listing.

Note:    If no exam grade is given, do not enter a weight for the exam.

Note:    Entering weights for one section of a course will enter the same weights
for any other sections of the same course.

An arrow will appear above the grade column that is to be calculated.

A listing of the weights you have set in all of your classes may be printed for review
by selecting Course Weights under the Edit menu on the main window.

Calculating Course Grades:
Course grades for a class may be calculated by selecting Calculate Grades under the
Options menu.

Course grades may be calculated for all classes at once by selecting Calculate All
Classes under the Edit menu on the main window.

No course grade will be calculated if:
a weight is entered for a grade but the grade is missing,

OR
a grade involved in the calculation does not count in the GPA.

Locking a Grade:
1. To give a student a grade other than the calculated grade, enter the desired

grade for the student.

2. Highlight the grade by clicking on it.

3. Click on the Lock Grade button or select Lock Grade under the Options
menu.  The locked grade will appear with a box around it.

Note:    When grades are calculated, the locked grade will not change.

Unlocking a Grade:
To unlock a locked grade, highlight the grade and click on the Unlock Grade button in
the lower left corner of the window or select Unlock Grade under the Options menu.
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Printing Grades and Comments:
To print the student grades in the displayed class, select Print this Class under the
Options menu.

The Print option under the File menu on the main window will print ALL class lists with
student names, grades, and comments for the term you select.

Standards and Benchmarks Assessments:
Student Standards and Benchmarks Assessments may be created, deleted, or edited on
either by course/grade or by student.

Edit Assessments for a Course or Grade:

1. Select Edit Assessments for a Course or Grade… under the Edit menu.

Figure 2: Edit Assessments for a Course or Grade screen with calculated results.
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Figure 3: Edit Assessments for a Course of Grade with manual results.

2. Select the desired course section or grade level from the Course or Grade menu
in the top right corner of the window.

3. Select the desired subject area from the Subject Area menu in the top right corner
of the window.

4. Select the desired standard from the Standard menu in the top right corner of the
window.

5. Select the desired assessment (benchmark or standard) from the Assessment
menu in the top right corner of the window.

Note:    Only standards and/or benchmarks that have been instanced for this
course or grade level will be listed in the Assessment menu.  If you need to
assess a standard and/or benchmark that is not in this menu you will need to
have an instance created for your course or grade level in the JMC Office
Application.  Once this is instanced in the office you may do an Office to
Teacher to update the Standards and Benchmarks definitions in your
GradeBook folder.

6. If viewing or editing an existing set of student assessments, select the desired date
from the Date menu in the top left corner of the window.
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Add    To add a new set of student assessments for the currently specified course or
grade level, subject area, standard, and assessment selections, click Add.  You will
then be prompted to enter more information.  If you are adding an assessment set for
a benchmark, the window will appear similar to Figure 4. If you are adding an
assessment set for a standard, the window will appear similar to Figure 5.

Note:    A student may have only one record per date and standard or
benchmark instance (term is ignored in this regard).

Figure 4: Add Assessment Set screen for a Benchmark.

Assessment Date    Enter the assessment date for this new set of results.  If this is
to be a calculated benchmark results set, this date will be used as a cutoff date for
assigment scores. If this is to be a calculated standard results set, this date will be
used as a cutoff date for benchmark results.

Manual    To create a set of blank records for the assessment, click Manual.  You
may then enter the desired student results manually.

Calculated    To create a set of calculated results for the assessment, click
Calculated.  If the currently calculating a standard result, a screen similar to
Figure 5 will appear with a summary of the calculation that is about to happen.

Figure 5: Add Assessment Set screen for a Standard.

Note:    Standards calculations option: When calculating a standard result, a
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Cumulative – All Terms checkbox is visible on the Add Assessment Set
screen (see Figure 5).  This option affects whether standard assessment
calculations are to use benchmark results from all terms or from the currently
selected term.

Note:    Standard Results are calculated based upon the most recent set of
benchmark assessments that pertain to this standard for the class.  The
summary window, similar to Figure 6, will display a list of benchmarks and
the date of the most recent assessment for each benchmark.  If you do not
wish to keep the standard results that are about to be created, do not save the
new set of standard results once the calculation has completed.

Figure 6: Summary for Adding a Standard Assessment Set.

Note:    Weighting for Standard or Benchmark Results Calculations may
be edited by selecting Standards and Benchmarks… from the Scores menu.

Note:    Benchmark Results are calculated based upon the current scores for
assignments that have been attached to a benchmark in your JMC GradeBook.
Assignments may be attached to a benchmark by selecting Categories and
Assignments from the Scores menu and clicking the Select Benchmark
button for the appropriate assignment(s).

Note:    After a result set is calculated, some students’ results may be a box
with no result or percentage.  In these cases, a result could not be calculated.
If this is a standard assessment, this may be due to the student having a locked
(non-calculated) result for one of their most recent benchmark results or they
may have no benchmark results at all to use for this calculation; therefore,
there is not enough information to calculate the result.  If this is a benchmark
assessment, this may be due to the student not having any assignment scores
on which to base a benchmark result calculation.

Note:    Result symbols (e.g. HP, PR, NP, etc.) and cutoffs (90% or better for
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an HP, etc.) are established in the office for each subject area.  You will not be
allowed to enter a result manually that is not defined in the office for the
specified subject area.

Cancel    To leave this window and return to the Edit Assessments for a Course
or Grade… window, click Cancel.

Delete    To delete the currently displayed assessment (set of results), click Delete.
Deleting of a result set will cause them to be deleted in the office database the next
time the teacher submits standards and benchmarks results to the office via Teacher
to Office.

Recalculate    To recalculate the currently displayed assessment (set of results), click
Recalculate.  The assessment will be recalculated based upon the current set of
assignment scores and benchmark results.

Locked Results    To give a student a result other than the calculated result, enter the
desired result for the student by selecting the result and then editing it.  A box will
appear around the result indicating that it is a locked result and the result percentage
will no longer be dislpayed.  If the result is then unlocked, the result percentage will
have been set to zero and the corresponding result will be set accordingly.

Fill    To copy a manually entered result from one student to all students for the
currently displayed assessment set, select the result to be filled and then click Fill.
This option may be useful if many students in a course or grade level are to receive
the same result on an assessment.  For example, let’s say that all students in the class
but one were proficient (for this example we will use a result of PR to indicate
proficient).  This can be accompished by adding a new assessment set (manual, not
calculated), then entering the result for the first student, then selecting that result by
clicking on it to hilite it, and then clicking Fill.  All students will now have the same
result.  You may then go through and manually edit any student(s) that received a
different result.

Note:    The Fill button is disabled if a manually entered result is not selected.
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Edit Assessments for a Student:

1. Select Edit Assessments for a Student… under the Edit menu.

Figure 7: Edit Assessments for a Student screen.

2. Select the desired course section or grade level from the Course or Grade menu
in the top right corner of the window.

3. Select the desired subject area from the Subject Area menu in the top right corner
of the window.

4. Select the desired standard from the Standard menu in the top right corner of the
window.

5. Select the desired student from the Student menu in the top right corner of the
window.

6. If viewing or editing an existing set of student assessments, select the desired date
from the Date menu in the top left corner of the window.

Add    To add a new set of assessments for the currently specified course or grade,
subject area, standard, and student, click Add.  You will then be prompted to enter
more information with a window will appear similar to Figure 8.
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Figure 8: Add Assessment Set for a Student screen.

Note:    A student may have only one record per date and standard or
benchmark instance (term is ignored in this regard).

Assessment Date    Enter the assessment date for this new set of results.  If this is to
be a calculated benchmark results set, this date will be used as a cutoff date for
assignment scores. If this is to be a calculated standard results set, this date will be
used as a cutoff date for benchmark results.

Manual    To create a set of blank records for the student, click Manual.  You may
then enter the desired student results manually.

Calculated    To create a set of calculated results for the assessment, click
Calculated.

Standards calculations option: If the currently specified standard is instanced for
the selected course or grade level, a Cumulative – All Terms checkbox is visible on
the Add Assessment Set screen (see Figure 8).  This option affects whether standard
assessment calculations are to use benchmark results from all terms or from the
currently selected term.

Note:    Standard Results are calculated based upon benchmark assessments
that pertain to this standard for the class that are as of the date specified for the
assessment set currently being created.  They are NOT based on stored
benchmark assessments like they would be if they were created on the Edit
Assessments for a Course or Grade screen.

Note:    Benchmark Results are calculated based upon the current scores for
assignments that have been attached to a benchmark in your JMC GradeBook.
Assignments may be attached to a benchmark by selecting Categories and
Assignments from the Scores menu and clicking the Select Benchmark button
for the appropriate assignment(s).

Note:    Weighting for Standard or Benchmark Results Calculations may be
edited by selecting Standards and Benchmarks… from the Scores menu.
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Note:    After a result set is calculated, some students’ results may be a box with
no result or percentage.  In these cases, a result could not be calculated.  If this is
a standard assessment, this may be due to the student having a locked (non-
calculated) result for one of the currently calculated benchmark results; therefore,
there is not enough information to calculate the result.  If this is a benchmark
assessment, this may be due to the student not having any assignment scores on
which to base a benchmark result calculation.

Note:    Result symbols (e.g. HP, PR, NP, etc.) and cutoffs (90% or better for an
HP, etc.) are established in the office for each subject area.  You will not be
allowed to enter a result manually that is not defined in the office for the specified
subject area.

Cancel    To leave this window and return to the Edit Assessments for a Student…
window, click Cancel.

Delete    To delete the currently displayed assessment (set of results), click Delete.
Deleting of a result set will cause them to be deleted in the office database the next
time the teacher submits standards and benchmarks results to the office via Teacher
to Office.

Result List    A list of results that are defined for the currently specified subject area
are displayed on the right side of the Edit Assessments for a Student… screen (see
Figure 8).  When a result is clicked in this list, the selected result will be placed in the
currently selected result ID cell in the student results list.
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Teacher to Office:
This option is used to submit grades and/or standards and benchmarks assessments to the
office.

In the Office
Take your JMC GradeBook disk to the office after entering grades and/or
generating assessments for the marking period.

Over a Network
1. Under the File menu, select Teacher to Office.  A window may appear asking

you to select the Grades Drop Folder.  Your network administrator will be
able to tell you the location of your drop folder.

2. After locating the drop folder, click the button Select “Grades Drop Folder”.

Note:    Be certain to select your Network Drop folder, NOT your GradeBook
folder.

3. If your GradeBook is capable of maintaining standards and benchmarks as
well as grades, you will then see a screen similar to Figure 9.  If you get this
screen, specify which type(s) of data to submit to the office, then click OK.

Figure 9: Teacher To Office – specify which type(s) of data to send

4. Your current grades and comments and/or standards and benchmarks
assessments will be sent to the Drop Folder for office use.   At a later time, the
office staff will pull in this data using a similar Teacher To Office process.

When Finished Using the GradeBook:
Select Quit (Exit) under the File menu on the main window.

Note:    Information about making backups of the GradeBook data may be found at
the end of this document.
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Necessary Tasks Before Recording Scores:
Before being able to record assignment scores, two steps need to be taken:

1. Define Grade Cutoffs
2. Define Categories and Assignments

Defining Grade Cutoffs:
This section is used to define the cutoffs for grades (e.g. “A” = 95—100%).  A set of
grade cutoffs should be defined for each class each marking period.  Student grades
cannot be calculated until cutoffs have been defined for the class.  The grades used must
be defined in the office.

Figure 11: Grade Cutoffs screen.

1. Select Grade Cutoffs under the Scores menu.   The screen will appear similar to
Figure 11.

2. Select a course section from the Course menu.

3. Starting at the top of the list, enter the highest grade given (e.g. “A”) in the left
column and the lowest percentage needed to achieve that grade (e.g. “95”) in the
right column.

4. Press the ‘tab’ key to change columns and the ‘up’ and ‘down’ arrows to change
rows.

Note:    You may also highlight by clicking on the desired location.

5. Continue to enter the rest of the possible grades followed by the percentage
needed to achieve that grade.
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IMPORTANT:  Your last grade and percentage should be a failing grade with a
percentage of zero (“F” = “0”).
 
 Click on Copy to other Classes to duplicate the current grade cutoffs to other

classes.
1. Select the classes to receive the current grade cutoffs.

2. Clicking on a class places a checkmark next to the class.  Checkmarked
classes will receive the current grade cutoffs.

Note:    To select all classes, click on the Copy to ALL Classes button.

Defining Categories and Assignments:
This section is used for defining your assignments and the categories to which those
assignments belong.  For example:  A category named Tests may be defined which
consists of individual tests, referred to as assignments.

Figure 12: Categories and Assignments screen.

The overall weighting of your categories may be by individual category weights or total
points.

1. If Total Points is selected, all calculations are based simply on the number of
points.

2. If you select Weights, then you MUST enter a weight for each category.



20 of 38

JMC Network GradeBook Documentation Last update on 12/15/05

1. Adding Categories:
1. Select Categories and Assignments under the Scores menu.

2. Click on the Add Category button. The Category will appear under the
currently highlighted line.

3. In the upper-right, enter the name of the Category.

4. Click on Enter to register the category.

Note:    Enter only categories for the current marking period.

2. Category Characteristics:
To set the characteristics of a category, click on the category name.  The current
settings are displayed on the right.

Weight:  Refers to the amount the category average counts towards the overall grade.

Note:  Category weights DO NOT have to total 100%.

Assignment Weights:  Displays how the assignments are being weighted towards the
category average.  Assignments may be weighted in these ways:

- Equally – the assignments will each count the same towards the category
average.

- By Points – the weight of each assignment towards the category average
is based on the number of points the assignment is worth.

- User-Defined – you will enter the assignment’s weight towards the
category average by clicking on the assignment name.  A weight box will
appear to the right.

# of Low Scores to Drop: Allows you to define the number of low scores in the
category to be dropped from the student’s grade calculation.

Stand-Alone category: By “X”ing this box, the category percentage will be
composed entirely of one score.  A Max Score must be entered which represents the
total points possible for the category.

Extra-Credit category: If checked, the category and any assignments in that
category count for extra credit.  No penalty will be given for missing an extra-credit
score.  You may define more than one extra-credit category.

Delete:  Deletes the currently selected category or assignment.

WARNING:  Any scores entered for this assignment will also be deleted!

Cancel: Disregards any changes made on the screen and to exit the screen.

OK: Saves any changes and exits.

Copy to Other Classes: Copies categories and/or assignments to other classes.  First
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choose which categories/assignments to copy.  Then select the classes to copy the
categories/assignments into.

Figure 13: Categories and Assignments screen with an assignment selected.

3. Adding Assignments:
Assignments are the individual scores that comprise the category.

To enter an assignment:
1. Click on the category to which the assignment belongs or the last assignment

currently listed in that category.

2. Click on the Add Assignment button. Please note the new assignment will
appear on the line underneath the currently highlighted line.

3. Once you have entered the assignment name, click on Enter.

4. The assignment will register under the category name.

Max Score:  Edits the maximum possible assignment score or stand-alone
category score.  

Note:    Scores may be entered to one decimal place.

Date:  Edits the assignment or stand-alone category date.

Note:    The date is used in determining “in-progress grades” and
for inclusion on reports.

Note:    JMC recommends that you use dates with all your
assignments.
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Weight:  Only editable when using User-Defined weights.

Note:    Weight of assignment towards the calculation of the
category average.

4. Attaching an Assignment to a Benchmark:
An assignment may be attached to a benchmark for the purpose of calculating a
benchmark result.  More than one assignment may be attached to a benchmark.
Weighting of multiple assignments in a benchmark calculation may be edited on the
Standards and Benchmarks screen in the Scores menu.

To attach an assignment to a benchmark:
1. Click on the assignment in the list on the left side of the screen to highlight it.

The screen will appear similar to Figure 13.

2. Click Select Benchmark.

Note:    You may need to perform an Office To Teacher from the file menu
to download local up-to-date copies of the standards and benchmark
definitions files into your GradeBook folder.

3. Select the appropriate Standard from the menu, then select the appropriate
benchmark by either double-clicking it or by highlighting it and then clicking
OK.

Note:    To remove/unattach an assignment from a benchmark, follow the
same steps listed but select the “No Benchmark” option at step 3.

Weighting Standards and Benchmarks:
Select the Standards and Benchmarks option under the Scores pull-down menu.  The
screen will display the assignmnents that are attached to each benchmark for a standard
and course.  This section is used for weighting the assignments that are attached to
benchmarks and also to weight benchmarks within a standard.
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Figure 14:  Standards and Benchmarks screen – setting weights.

The overall weighting of assignments within a benchmark may be equally weighted, by
total points, or user defined.

1. If Equal is selected, all assignments will be weighted equally, e.g. 4
assignments each weighted 25%.

2. If Total Points is selected, all calculations are based simply on the number of
points.

3. If User Defined is selected, you may edit the weights for each assignment as
you see fit.  Click on each assignment to edit their respective weights.

The overall weighting of a standard is by weights only.  The weight of each benchmark in
the standards result calculation may be set by highlighting the benchmark in the list at the
left side of the Standards and Benchmarks screen and entering the desired weight in the
Weight box in the middle of the screen.  By default all benchmarks are weighted equally
for a standard.

Entering Assignment Scores:
Select the Assignment Scores option under the Scores pull-down menu.  The screen
will display a class with one student per row and one assignment per column, similar
to Figure 15.
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Figure 15:  Assignment Scores screen.

The columns may be sorted by date or category – see Figure 16.  When sorting by
date, be sure a date has been entered for each assignment on the Categories and
Assignments screen in the Scores menu.

Assignment Scores Screen Sort Order Preferences

The columns may be sorted by date or category.  When sorting by date, be sure a date
has been entered for each assignment.  To change this sort citerion, select
Preferences form the appropriate menu, then select the desired sort option.  See
Figure 16.

Figure 16: Preferences for Assignment Score Screen.

Editing Student Assignment Scores

- To select a cell (the intersection of a student’s row and an assignment column) in
the scores list, either click on the desired cell or use the keyboard to move the
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selection rectangle to the cell.

Note:    Under Edit you may select Cut/Copy/Paste or use keyboard shortcuts.

Note:    Use scroll bars or movement keys to bring the desired
student/assignment into view.

Down = <Return>, <Enter> or <Down-Arrow>
Movement Keys: Up = <Up-Arrow>

Left = <Shift-Tab>
Right = <Tab>

- To enter a score, select the cell for the student in the correct column and type the
score.  Scores may be entered with one decimal place.

- To enter another score, press one of the movement keys or click the desired cell
and type the score.

Score-Exemption and Non-Scores:
- A “.” (period) in a column means that a score has not yet been entered for the

student.

- A score of 0 (zero) in a column indicates that the student has received no credit
for the assignment.

- An “X” in a column means that the student is exempt from the assignment.

Late Assignments:
- Late Included—“LI”- By entering an “LI” on the Assignment Scores screen for

an assignment, the computer will be including the late assignment as a ZERO.

- Late Exempt—“LX”- By entering an “LX” on the Assignment Scores screen for
an assignment, the computer will NOT include the late assignment in calculations.

Note:    An “LX” or “LI” is considered a missing score. Convert Missing
Scores to Zero and the Missing Scores Report will treat the “LX” and “LI” as
missing scores.

Assignment Note:
You can attach a free-hand comment to any assignment score.

To edit/enter a note:
- Hold down the Option key while clicking on the desired assignment score.

OR
- Highlight the score by clicking or using the Movement keys and then once the

desired assignment is highlighted, go under the Options menu to Edit Score
Note.

An assignment score that has a note attached to it will display an “*” to the right of
the score.  The Score Note will print on Student Summaries and Progress Reports.
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Print Student:
Prints a Student Summary Report for the currently selected student only.  The report
shows all of the scores for the student along with the student’s current grade and
percentage.  This report may also be obtained by double-clicking a student name.

Clear Score:
If a score is entered incorrectly, select the score and press the Clear Score button.
The score will be reset to a “no score” or “.”.

Save:
Saves any changes that have been made on the Assignment Scores screen.

Current Assignment: (Not Editable)
Gives the full name of the currently selected assignment or stand-alone category in
the lower left-hand corner of the screen.

Double-clicking an assignment header brings up the Edit Categories & Assignments
screen.

Locked Grades:
To override a calculated grade, click on the grade and select the desired grade from
the pop-up menu.

- When you release, a box will appear around the student’s grade.  This informs
you that the grade is locked and is not the result of calculations.

- To return to the calculated grade, click on the locked grade and select
Calculated from the pop-up menu.

Options Menu:
The Options pull-down menu allows you to choose between viewing all students or
one student at a time on the Assignment Scores screen.  Viewing one student at a time
is especially useful during conferences.

- You may also select the column order.   Columns may be sorted by date or by
category.

- By selecting Edit Score Note, you are able to enter/edit assignment notes.

- The Fill Score Column gives the selected score to all students for an assignment.

Reporting “In-Progress” Grades:
The Electronic GradeBook allows “in-progress” grades to be captured and transferred
to the office.  These “in-progress” grades can be used by the office for midterm
report cards or eligibility checking.
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To capture “in-progress” grades:
1. Select Assignment Scores under the Scores menu.

2. In the upper right of the window under the term, the word Current will appear.

3. Click on the pop-up menu displaying Current and select Midterm.
A box will appear with the word Date.

4. Enter the midterm date.

Assignments through this date will be included in the “in-progress” calculation.

To edit “in-progress” grades:
“In-progress” grades may be edited:

- on the Assignment Scores screen
OR

- by selecting Midterm Grades under the Edit menu on the main window.

To override a calculated “in-progress” grade:
1. Click on the grade and select the desired grade from the pop-up menu.

2. When you release, a box will appear around the student’s grade, informing you
that the grade is locked and is not the result of calculations.

- To return to the calculated grade, click on the locked grade and select
Calculated from the pop-up menu.
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Reports:
Important Note: All percentages are now rounded to the nearest integer on Reports.

New Progress Report Setup:  Use this section to prepare student progress reports.
1. Select New Progress Report Setup under the Reports menu.

2. Name the file to be saved. A new screen will be displayed which will appear
similar to Figure 17.

Figure 17:  Progress Report Setup screen.

3. Enter the desired date in the Report Date field and press the <Enter> key.

Note:  Student grades will be calculated as of the date entered in the Report
Date field.

4. Select the course/period/term you wish to prepare.

5. Once the report date is set, information for each student may be entered.
To edit the information:

1. Select the student’s name in the list.
2. Click on the comment(s) that should be printed for the selected

student.
3. To exclude a comment, click on it again.

Note:  The list of comments is Teacher-defined.  You may edit the master list (See
Reports—Edit Comments).    Up to 254 characters of additional comments may
be hand-entered in the Additional Comments field to be printed on the progress
report.
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6. To mark a student to be printed, click in the printer column next to the the
student’s name.  Only students with a dot next to their name will be printed.

• To mark all students to be printed, click the Print All button
• To print no students, click the Print None button.

• If the Include Present Grade box is checked, each student’s current
percentage and grade will be printed.

• If the Include Score Summary box is checked, the progress report will
include a student summary for each student selected.  (See
Reports—Student Summary)

• To print students above or below a certain percentage, use the corresponding
print button.

7. To edit progress report information for other classes, select a new
course/period/term.

8. When finished, click the Done button.

• The information is stored in your named progress report.
• This information may now be printed/edited.  (See Reports—Print Progress

Reports/Edit Progress Reports)

Note:    You may create as many differently named progress report setup files as
you wish.  These files will remain where saved until you delete them.

Edit Progress Report Setup:  This option is used to change information in a previously
created progress report file. (See Reports—New Progress Report Setup)

1. Select Edit Progress Report Setup under the Reports menu.

2. In the file dialog, select a report file to edit and click Open.
All information may now be edited.  (For editing tips, see Reports—New

Progress Report Setup)

3. When finished, click the Done button.  Any changes will be updated in that
progress report setup file.  The edited progress reports may now be printed or edited
again.  To print, see Reports—Print Progress Reports.

Print Progress Reports:  This selection is used to print a previously created progress
report.  The report includes:

• the student’s grades as of the entered report date if requested,
• any missing scores for assignments on or before the report date,
• any selected comments for the student, along with any additional

comments entered by the teacher,
• a Student Summary, if selected by the teacher (See Reports—New

Progress Report Setup to include a Student Summary on the printed
Progress Report), and
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• the student’s advisor.

1. Select Print Progress Reports under the Reports menu.

2. Select a previously created progress report file in the file dialog and click Open.

- All students previously marked with a “dot” character on the Progress Report
Setup screen will now be printed with their current grades and comments.

Note:     If the wrong students are being printed, check the progress report
setup screen.  (See Reports—Edit Progress Report Setup)

Send Progress Reports to Office:  This selection is used to send a previously created
progress report to the office.  In the office, progress reports may be processed in various
ways, such as printing by grade level or for a particular student.

The report includes:
• the student’s grades as of the entered report date if requested,
• any missing scores for assignments on or before the report date,
• any selected comments for the student, along with any additional

comments entered by the teacher,
• a Student Summary, if selected by the teacher (See Reports—New

Progress Report Setup to include a Student Summary on the printed
Progress Report), and

• the student’s advisor.

1. Select Send Progress Reports to Office under the Reports menu.

2. Select a previously created progress report file in the file dialog and click Choose.

- All students previously marked with a “dot” character on the Progress Report
Setup screen will now be printed with their current grades and comments.

Note:     If the wrong students are being sent to the office, check the progress
report setup screen.  (See Reports—Edit Progress Report Setup)

Edit Comments:  This option is used to edit the master list of 64 standard comments
used on student progress reports.

Select Edit Comments under the Reports menu.
To edit a comment:

1. Click on the comment and type a new comment.

2. Use the <Enter> or <down arrow> key to move down the list and the <up
arrow> key to move up the list.

- To save changes, click the Update button.

- To print a list of the current comments, click the Print button.
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Note:     Any changes made to the comment list will also appear when printing
any existing progress report files.

Missing Scores:  This report finds all students who are missing one or more assignment
scores.  The report checks all assignments with dates on or before a given date in the
selected term. The report will include assignments marked as late.

1. Select Missing Scores under the Reports menu.

Note:    The screen defaults to the current term selected.

Note:     To run a report for another term, exit the Missing Scores screen and
select the desired term under the Term menu.

2. Enter the desired date in the date box.

Note:     To check assignments with no dates, clear the date box and continue.

3. Choose either the student name option or the student number option (for
anonymity).

4. Click the Print Extra Message checkbox to print a one-line message with each
student.  Type the message in the message field.  (e.g.  “All make-up work due
June 1.”)

5. Click OK.

Note:     The report will print the assignment names and dates of missing
scores for each student.  If a student is not missing any scores, he/she will not
print on the Missing Scores Report.

Student Summary:  This selection prints a breakdown of all assignment scores by
student.  The report will print a one-two page summary per student for the selected
course/period/term.

1. Select the Student Summary option under the Reports menu.

2. Select the desired course/period/term.

3. To select a student, click on the student’s name in the list.  To deselect a student,
click again.

Note:     To print all students, click Print All.  To print no students, click
Print None.

- For each student selected, a summary will be printed with the current grade and
percentage along with a score and percentage by category and assignment.

Note:     A “.” appears when a score is missing.  An “X” appears when the
student is exempt from the assignment.
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Note:     If an assignment has been dropped due to a low score, a note will
print next to the score.  (See # of low scores dropped in Score—Categories
and Assignments)

Assignment Summary:  This selection prints student scores and percentages for
particular assignments in the selected course/period/term. The class mean, median,
maximum and minimum print at the end of the report.
  

1. Select Assignment Summary from the Reports menu.

2. Select the desired course/period/term.

3. Choose either print student name or student number.

4. Select the desired category or assignment by clicking on the category/assignment.

Note:    A “.” denotes a missing score.  An “X” denotes an exempt score.

Note:    If a score was dropped due to a low score, a note will print next to the
score.

Grade Summary:  This selection prints the marking period grade and percentage for
each student in the selected course/period/term. The class mean, median, maximum and
minimum print at the end of the report.

1. Select Grade Summary from the Reports menu.

2. Select the desired course/period/term.

3. Enter the desired date in the date field box.

Note:  The report will calculate a grade using assignments on or before the
date entered.

Note:  A note will be printed for missing scores on or before the date entered.

Scores Grid:  This report prints student scores in a gradebook page format with
assignments across the top of the page and student names/numbers down the left-hand
side.

1. Select Scores Grid from the Reports menu.

2. Select the desired course/period/term from the pop-up menu.

3. Enter the desired date in the date box.

Note:  Only assignments on or before the date entered will be printed.
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4. Choose either student name or student number to print on the report.

Class Assignments:  This report prints the categories and assignments for the selected
class(es).  It includes the weight, points possible, and date of each assignment.

1. Select Class Assignments from the Reports menu.

2. To select a class, click on the class name in the list.  To deselect a class, click
again.

Note:  To print all classes, click Print All.  To print no classes, click Print None.

Blank Score Sheets:  Produces a grid with student names for the selected class.  The
blank grid is useful for entering assignment scores for later entry into your GradeBook.

Student Name and Number List:  Produces a list of student names and numbers for
reference when using print-outs that only include one or the other.

Student Assessment Summary:  This selection prints a breakdown of all Standards and
Benchmarks assessments by student.  The report will print a one-two page summary per
student for the selected course/period/term, subject area(s), and standard(s).

1. Select the Student Assessment Summary option under the Reports menu.

Figure 18:  Student Assessment Summary Report criteria screen.

2. Select the desired course or grade, subject area(s), and standard(s).

3. To select a student, click on the student’s name in the list.  To deselect a student,
click again.

Note:     To print all students, click Print All.  To print no students, click
Print None.



34 of 38

JMC Network GradeBook Documentation Last update on 12/15/05

4. For each student selected, a summary will be printed with the current grade and
percentage along with a score and percentage by category and assignment, similar
to Figure 19.

Figure 19: Sample Printout for Student Assessment Summary Report

Note:     A standard result may be incalculable if there are benchmarks for that
standard for which no benchmark result can be calculated for the day the
report is being generated.

Note:     A benchmark result may be incalculable if there are assignment
scores for the attached assignments.
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Other Options:

Preferences (under the File menu):
• The window contains a checkbox to turn off the “greater than maximum score”

warning.

• The “Round Percentages to Determine Grade” checkbox will affect grade
calculations.  For example, with this box checked, an 89.9% would be rounded to
a 90% to determine the marking period grade.  On the other hand, if the box were
unchecked, an 89.9% would be considered 89% when determining the marking
period grade.

• The “Always Use Letter Grades to Calculate Course Grades”, if checked, will
not utilize the percentages when determining the Course Grade.  The program will
use the letter grade values from the Office.

Convert Missing Scores to Zero:  WARNING: This action is irreversible!!
This screen finds all missing and late scores for all courses/periods/terms through the date
entered in the date box and converts them to zero.  This option is useful for changing
scores after a late deadline or at the end of the marking period.

1. Select Convert Missing Scores under the Scores menu.

2. Enter the desired date in the date box.

3. Click OK.

Utilizing Progress Reports and “In-Progress” Grades without
Recording Assignments:

Progress Reports – Grades may be entered on the Assignment Scores screen by
clicking to the right of the 0.0%.  A pop-up will appear with the possible grades.  Select
the grade and release.  The grade will appear when Progress Reports are printed.  Refer
to the section Progress Reports for directions and options.

In-Progress Grades – In-Progress grades may be entered for transmittal to the office.
The office can use the grades to print out Midterm report cards or perform athletic
eligibility checking.  The “in-progress” grades are sent to the office by performing a
Teacher to Office.  These grades are entered by selecting Midterm Grades from the
Edit menu on the main screen.
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Seating Charts:

1. Under the Edit menu, select Seating Charts.  A screen will appear similar to
Figure 20.

Figure 20: Edit Seating Charts screen

Course Menu    To view or edit seating charts for a different class, select the correct
period and course from the Course menu.

Dim Menu    To change the dimensions for a seating chart, select the dimension from the
Dim menu.  Options include 7x7 or 12x12.

Note:    When switching dimensions, existing seating charts may not look right.
If you wish to switch the dimensions for the seating chart for a course that already
had a seating chart, you may wish to clear the seating chart and start over.

Note:    User preference for seating chart dimensions is stored.  For teachers who
choose to create seating charts in both 7x7 and 12x12, when switching courses in
the Course menu the dimension may also need to be switched in the Dim menu.
For now, the dimensions that a seating chart was created in are not stored within
the seating chart.

Adding Students to the Chart    To add a student to the seating chart, drag the student
from the students list on the left side of the screen to the seating chart.  Once the student
has been placed in the seating chart, a check mark will appear next to their name in the
student list.
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Removing Students from the Chart    To remove a student to the seating chart, drag the
student off of the chart.  Once the student has been removed from the seating chart, a
check mark will disappear next to their name in the student list.

Snap to Grid    When the Snap To Grid checkbox in the lower left corner of the screen
is checked, students will be placed within one of the preset locations within the seating
chart.  These preset locations fall within a 7-row by 7-column grid that allows up to 49
students per chart, or a 12-row by 12-column grid that allows for up to 144 students per
chart.  When the Snap To Grid checkbox is unchecked, students can be placed anywhere
on the seating chart.  This would allow for arrangements other than rows and columns,
such as a semicircle.

Note:    By default, the Snap To Grid checkbox is checked every time you arrive
at the edit seating chart screen.

Randomize    To randomly change the order of an existing seating chart, click
Randomize.  This option will only shuffle students that are already placed in the seating
chart and will only place them into positions that are already designated in the seating
chart.

Clear To clear the selected seating chart, click Clear.

Print    To print the currently displayed seating chart, click Print.

Save    To save the currently displayed seating chart, click Save.

Done    To leave the seating charts screen and return to the main screen of the JMC
GradeBook, click Done.
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Backing-up the Teacher GradeBook software:

Making a Backup of your GradeBook data from your hard drive to a disk:

Note:  You will need a back-up disk and you must quit the JMC GradeBook
program before backing-up.

Note:  You may also be able to make a backup of your JMC GradeBook data
a server or other storage device.  Check with your school’s technology
coordinator or network administrator to find out what options you may have
available.

1. Insert your back-up disk.

2. Locate the GradeBook folder on your hard drive.

3. Drag or Copy and Paste your GradeBook folder onto the back-up disk you have
inserted.  A window will appear showing the copy progress.  When it is complete,
you will have a back-up of your JMC GradeBook on the disk.

4. Locate and rename the GradeBook folder on your back-up disk.  Include the
current date and the word “back-up”.

Note:    It is important to rename the folder to avoid possible confusion in the
future.

5. It should be sufficient to keep one back-up of the JMC GradeBook folder.  Back-
ups no longer needed should be thrown away by using the Trash Can/Recycle Bin
located on the computer’s Desktop.

6. When finished, eject the disk and store it in a safe location.


